using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"P.?\s?O.?\s?Box\s\d+";
string input = @"POBox 123, POBox 1234, P.O.Box 123, P.O.Box 1234, P O Box 123, P O Box 1234, P.O. Box 123, P.O. Box 1234, PO Box
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}