re = /P.?\s?O.?\s?Box\s\d+/
str = 'POBox 123, POBox 1234, P.O.Box 123, P.O.Box 1234, P O Box 123, P O Box 1234, P.O. Box 123, P.O. Box 1234, PO Box
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end