package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`P.?\s?O.?\s?Box\s\d+`)
var str = `POBox 123, POBox 1234, P.O.Box 123, P.O.Box 1234, P O Box 123, P O Box 1234, P.O. Box 123, P.O. Box 1234, PO Box
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}