// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"P.?\s?O.?\s?Box\s\d+").unwrap();
let string = "POBox 123, POBox 1234, P.O.Box 123, P.O.Box 1234, P O Box 123, P O Box 1234, P.O. Box 123, P.O. Box 1234, PO Box
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}