import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^']*(?=lamb)[^']*)";
final String string = "'Baa, baa, black sheep, have you any wool?\n"
+ "Yes sir, yes sir, three bags full!\n"
+ "One for the master\n"
+ "One for the dame'\n\n"
+ "'Mary had a little lamb,\n"
+ "its fleece was white as snow;\n"
+ "And everywhere that Mary went,\n"
+ "the lamb was sure to go.'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}