re = /([^']*(?=lamb)[^']*)/
str = '\'Baa, baa, black sheep, have you any wool?
Yes sir, yes sir, three bags full!
One for the master
One for the dame\'
\'Mary had a little lamb,
its fleece was white as snow;
And everywhere that Mary went,
the lamb was sure to go.\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end