import re
regex = re.compile(r"([^']*(?=lamb)[^']*)")
test_str = ("'Baa, baa, black sheep, have you any wool?\n"
"Yes sir, yes sir, three bags full!\n"
"One for the master\n"
"One for the dame'\n\n"
"'Mary had a little lamb,\n"
"its fleece was white as snow;\n"
"And everywhere that Mary went,\n"
"the lamb was sure to go.'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")