import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[link=https?:\\/\\/(www\\.)?([\\da-z\\.-]+)\\.([a-z\\.]{2,6})([\\/\\w \\.-](\\S*[&|#]\\S+)*)*\\/?\\][^\\s\\\\](.*?)\\[\\/link\\]";
final String string = "// Lolos\n"
+ "[link=https://namablog.com/]teks[/link]\n"
+ "[link=http://namablog.co.id/]teks[/link]\n"
+ "[link=http://namablog.com/2016/04/vita-denique-conferta-voluptatum-omnium.html]teks[/link]\n"
+ "[link=https://namablog.blogspot.com/2016/04/vita-denique-conferta-voluptatum-omnium.html?showComment=1468398368234#c4159204139756303657]teks[/link]\n"
+ "[link=https://namablog.blogspot.co.id/search?updated-max=2016-04-17T04:28:00-07:00&max-results=7/]teks[/link]\n\n"
+ "// Tidak lolos\n"
+ "[link=//namablog.com/]teks[/link]\n"
+ "[link=https://namablog.com][/link]\n"
+ "[link=https://namablog.com/]teks[/link\n"
+ "[link=https://namablog]teks[link]\n"
+ "[link=https://namablog.com/]teks/link]\n"
+ "[link=https://namablog.com/]teks[link]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}