import re
regex = re.compile(r"\[link=https?:\/\/(www\.)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-](\S*[&|#]\S+)*)*\/?\][^\s\\](.*?)\[\/link\]", flags=re.IGNORECASE)
test_str = ("// Lolos\n"
"[link=https://namablog.com/]teks[/link]\n"
"[link=http://namablog.co.id/]teks[/link]\n"
"[link=http://namablog.com/2016/04/vita-denique-conferta-voluptatum-omnium.html]teks[/link]\n"
"[link=https://namablog.blogspot.com/2016/04/vita-denique-conferta-voluptatum-omnium.html?showComment=1468398368234#c4159204139756303657]teks[/link]\n"
"[link=https://namablog.blogspot.co.id/search?updated-max=2016-04-17T04:28:00-07:00&max-results=7/]teks[/link]\n\n"
"// Tidak lolos\n"
"[link=//namablog.com/]teks[/link]\n"
"[link=https://namablog.com][/link]\n"
"[link=https://namablog.com/]teks[/link\n"
"[link=https://namablog]teks[link]\n"
"[link=https://namablog.com/]teks/link]\n"
"[link=https://namablog.com/]teks[link]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")