$re = '/\[link=https?:\/\/(www\.)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-](\S*[&|#]\S+)*)*\/?\][^\s\\\\](.*?)\[\/link\]/i';
$str = '// Lolos
[link=https://namablog.com/]teks[/link]
[link=http://namablog.co.id/]teks[/link]
[link=http://namablog.com/2016/04/vita-denique-conferta-voluptatum-omnium.html]teks[/link]
[link=https://namablog.blogspot.com/2016/04/vita-denique-conferta-voluptatum-omnium.html?showComment=1468398368234#c4159204139756303657]teks[/link]
[link=https://namablog.blogspot.co.id/search?updated-max=2016-04-17T04:28:00-07:00&max-results=7/]teks[/link]
// Tidak lolos
[link=//namablog.com/]teks[/link]
[link=https://namablog.com][/link]
[link=https://namablog.com/]teks[/link
[link=https://namablog]teks[link]
[link=https://namablog.com/]teks/link]
[link=https://namablog.com/]teks[link]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);