#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){([^{}]*(?:{{[^{}]*}}[^{}]*)*)}"
Local $sString = "identifier{ {{var1}} rest of the {{var2}} {{var3}} content{{something var related}}fdfd} outer content identifier{ {{var2}} another content} identifier{ content with no vars }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")