re = /{([^{}]*(?:{{[^{}]*}}[^{}]*)*)}/m
str = 'identifier{ {{var1}} rest of the {{var2}} {{var3}} content{{something var related}}fdfd} outer content identifier{ {{var2}} another content} identifier{ content with no vars }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end