using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{([^{}]*(?:{{[^{}]*}}[^{}]*)*)}";
string input = @"identifier{ {{var1}} rest of the {{var2}} {{var3}} content{{something var related}}fdfd} outer content identifier{ {{var2}} another content} identifier{ content with no vars }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}