const regex = new RegExp('{([^{}]*(?:{{[^{}]*}}[^{}]*)*)}', 'gm')
const str = `identifier{ {{var1}} rest of the {{var2}} {{var3}} content{{something var related}}fdfd} outer content identifier{ {{var2}} another content} identifier{ content with no vars }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}