using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0[7-9]0-\d{4}-[0-9]{4}";
string input = @"080-1234-5678
070-9999-8888
060-1234-5555
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}