package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0[7-9]0-\d{4}-[0-9]{4}`)
var str = `080-1234-5678
070-9999-8888
060-1234-5555
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}