re = /0[7-9]0-\d{4}-[0-9]{4}/m
str = '080-1234-5678
070-9999-8888
060-1234-5555
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end