$re = '/0[7-9]0-\d{4}-[0-9]{4}/m';
$str = '080-1234-5678
070-9999-8888
060-1234-5555
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);