import re
regex = re.compile(r"^(?:(?:[a-z0-9_-]+|[a-z0-9_-]+\*|\*)\/)*([a-z0-9_-]+|[a-z0-9_-]+\*|\*|>)$", flags=re.MULTILINE)
test_str = ("my/simple/topic/123\n"
"my/simple/topic/123/>\n"
"my/simple/topic/123/*\n"
"my/simple/to*/123/*\n"
"my/simple/topic/*/*/>\n"
"*/simple/topic/>\n"
"my\n"
"*\n"
">\n\n"
"my/*imple/topic\n"
"my/simple/topic/\n"
"my/simple/topic/>/123\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")