re = /^(?:(?:[a-z0-9_-]+|[a-z0-9_-]+\*|\*)\/)*([a-z0-9_-]+|[a-z0-9_-]+\*|\*|>)$/m
str = 'my/simple/topic/123
my/simple/topic/123/>
my/simple/topic/123/*
my/simple/to*/123/*
my/simple/topic/*/*/>
*/simple/topic/>
my
*
>
my/*imple/topic
my/simple/topic/
my/simple/topic/>/123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end