#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^\d+\. +).+?(?=\n|$)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"Open Ended Questions:" & @CRLF & _
"1. What makes Vue a popular choice for web development?" & @CRLF & _
"2. How does Vue compare to other JavaScript frameworks?" & @CRLF & _
"3. What are the advantages of using Vue?" & @CRLF & _
"" & @CRLF & _
"Closed Ended Questions:" & @CRLF & _
"1. Does Vue support server-side rendering?" & @CRLF & _
"2. Is Vue compatible with TypeScript?" & @CRLF & _
"3. Does Vue have a built-in router?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")