const regex = /(?<=^\d+\. +).+?(?=\n|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^\\d+\\. +).+?(?=\\n|$)', 'gm')
const str = `
Open Ended Questions:
1. What makes Vue a popular choice for web development?
2. How does Vue compare to other JavaScript frameworks?
3. What are the advantages of using Vue?
Closed Ended Questions:
1. Does Vue support server-side rendering?
2. Is Vue compatible with TypeScript?
3. Does Vue have a built-in router?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}