import Foundation
let pattern = #"(?<=^\d+\. +).+?(?=\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Open Ended Questions:
1. What makes Vue a popular choice for web development?
2. How does Vue compare to other JavaScript frameworks?
3. What are the advantages of using Vue?
Closed Ended Questions:
1. Does Vue support server-side rendering?
2. Is Vue compatible with TypeScript?
3. Does Vue have a built-in router?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)