re = /(?<=^\d+\. +).+?(?=\n|$)/m
str = '
Open Ended Questions:
1. What makes Vue a popular choice for web development?
2. How does Vue compare to other JavaScript frameworks?
3. What are the advantages of using Vue?
Closed Ended Questions:
1. Does Vue support server-side rendering?
2. Is Vue compatible with TypeScript?
3. Does Vue have a built-in router?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end