re = /\/*(?<!\\)[^\/]*\/*(?<!\\)[^\/]*/m
str = '/10/102-\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end