const regex = new RegExp('^(?=(?:[^a-zA-Z\\n]*[a-zA-Z]){4}[^a-zA-Z\\n]*$)(?=(?:[^\\d\\n]*\\d){3}[^\\d\\n]*$)', 'mg')
const str = `t1E2S3T
t1E2S33`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);