$re = '/^(?=(?:[^a-zA-Z\n]*[a-zA-Z]){4}[^a-zA-Z\n]*$)(?=(?:[^\d\n]*\d){3}[^\d\n]*$)/m';
$str = 't1E2S3T
t1E2S33';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;