using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)(?=.*[a-zA-Z])([a-zA-Z\d]{10}$)";
string input = @"sasas12212
211212jknn
211212jknnd
2121212122
csdcdcdcdc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}