re = /^(?=.*\d)(?=.*[a-zA-Z])([a-zA-Z\d]{10}$)/m
str = 'sasas12212
211212jknn
211212jknnd
2121212122
csdcdcdcdc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end