use strict;
my $str = 'sasas12212
211212jknn
211212jknnd
2121212122
csdcdcdcdc';
my $regex = qr/^(?=.*\d)(?=.*[a-zA-Z])([a-zA-Z\d]{10}$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}