import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\d)(?=.*[a-zA-Z])([a-zA-Z\\d]{10}$)";
final String string = "sasas12212\n"
+ "211212jknn\n"
+ "211212jknnd\n"
+ "2121212122\n"
+ "csdcdcdcdc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}