# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\+31(14\d{3,5})(?=\D|$)/$1/gm;t' <<< "+3120345643
+311403
+3114035
+311402431
+31140457487"