#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\+31(14\d{3,5})(?=\D|$)"
Local $sString = "+3120345643" & @CRLF & _
"+311403" & @CRLF & _
"+3114035" & @CRLF & _
"+311402431" & @CRLF & _
"+31140457487"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)