const regex = /\+31(14\d{3,5})(?=\D|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+31(14\\d{3,5})(?=\\D|$)', 'gm')
const str = `+3120345643
+311403
+3114035
+311402431
+31140457487`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);