$re = '/\+31(14\d{3,5})(?=\D|$)/m';
$str = '+3120345643
+311403
+3114035
+311402431
+31140457487';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;