# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bAPIAuth(?:-\S+)?\s+//gm;t' <<< "APIAuth 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM=
APIAuth-HMAC-SHA256 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM="