re = /\bAPIAuth(?:-\S+)?\s+/m
str = 'APIAuth 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM=
APIAuth-HMAC-SHA256 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM='
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result