$re = '/\bAPIAuth(?:-\S+)?\s+/m';
$str = 'APIAuth 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM=
APIAuth-HMAC-SHA256 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM=';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;