const regex = /\bAPIAuth(?:-\S+)?\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bAPIAuth(?:-\\S+)?\\s+', 'gm')
const str = `APIAuth 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM=
APIAuth-HMAC-SHA256 5b6b7ed3b9708d1168455da4:hW1ZeYYLJFGBP8tEHAEGoiGD1xM=`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);