#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-fA-F0-9]"
Local $sString = "ab" & @CRLF & _
"abc" & @CRLF & _
"abcc" & @CRLF & _
"abccc" & @CRLF & _
"abcccc" & @CRLF & _
"abccccc" & @CRLF & _
"abcccccc" & @CRLF & _
"abcbcbcbc" & @CRLF & _
"abcbcbcbcbcbc" & @CRLF & _
"- _ { } @ "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")