package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-fA-F0-9]`)
var str = `ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc
- _ { } @ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}