re = /[a-fA-F0-9]/m
str = 'ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc
- _ { } @ '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end