using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=_)[^_]{2}(?=[^_]*$)";
string substitution = @"$1";
string input = @"sample_filename_AB12123321.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}