re = /(?<=_)[^_]{2}(?=[^_]*$)/m
str = 'sample_filename_AB12123321.pdf'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result