const regex = /(?<=_)[^_]{2}(?=[^_]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=_)[^_]{2}(?=[^_]*$)', 'gm')
const str = `sample_filename_AB12123321.pdf`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);