$re = '/(?<=_)[^_]{2}(?=[^_]*$)/m';
$str = 'sample_filename_AB12123321.pdf';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;