using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&
(?> (?<name>[a-zA-Z][a-zA-Z\d]++)
| \# (?> (?<dec>\d++)
| (?<hex>x[\da-fA-F]++)
)
)
;";
string input = @"http://foo.com/bar?foo=bar®ion=US®ister=lowpass®_test=fail&trademark=correct
& < >
∴ ¾
⇐ Ü Þ
	 〹
  ˜ © 𝌆 ☃";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}