// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sx)&
(?> (?<name>[a-zA-Z][a-zA-Z\d]++)
| \# (?> (?<dec>\d++)
| (?<hex>x[\da-fA-F]++)
)
)
;").unwrap();
let string = "http://foo.com/bar?foo=bar®ion=US®ister=lowpass®_test=fail&trademark=correct
& < >
∴ ¾
⇐ Ü Þ
	 〹
  ˜ © 𝌆 ☃";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}