import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "&\n"
+ "(?> (?<name>[a-zA-Z][a-zA-Z\\d]++)\n"
+ " | \\# (?> (?<dec>\\d++)\n"
+ " | (?<hex>x[\\da-fA-F]++)\n"
+ " )\n"
+ ")\n"
+ ";";
final String string = "http://foo.com/bar?foo=bar®ion=US®ister=lowpass®_test=fail&trademark=correct\n"
+ "& < > \n"
+ "∴ ¾\n"
+ "⇐ Ü Þ\n"
+ "	 〹\n"
+ "  ˜ © 𝌆 ☃";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}