package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)&
(?> (?<name>[a-zA-Z][a-zA-Z\d]++)
| \# (?> (?<dec>\d++)
| (?<hex>x[\da-fA-F]++)
)
)
;`)
var str = `http://foo.com/bar?foo=bar®ion=US®ister=lowpass®_test=fail&trademark=correct
& < >
∴ ¾
⇐ Ü Þ
	 〹
  ˜ © 𝌆 ☃`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}